mirror of
https://github.com/AsgardEternal/Squad.nix.git
synced 2024-12-28 22:29:17 -06:00
23 lines
532 B
Nix
23 lines
532 B
Nix
{
|
|
description = "Squad Servers NixOS Module";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
};
|
|
outputs = { self, flake-utils, nixpkgs }: (flake-utils.lib.eachDefaultSystem (system:
|
|
let
|
|
pkgs = nixpkgs.legacyPackages.${system};
|
|
in
|
|
{
|
|
devShells.default = pkgs.mkShell {
|
|
buildInputs = with pkgs; [
|
|
nixpkgs-fmt
|
|
];
|
|
};
|
|
|
|
})) // {
|
|
nixosModules.server = import ./modules/squad-server.nix;
|
|
};
|
|
}
|