Price Hiller
fe757ad6b1
Some checks failed
Check Formatting of Files / Check-Formatting (push) Failing after 47s
`networking.fqdn` is readonly.
21 lines
445 B
Nix
Executable File
21 lines
445 B
Nix
Executable File
{ hostname, ... }:
|
|
|
|
{
|
|
services.resolved = {
|
|
enable = true;
|
|
domains = [ "~." ];
|
|
dnsovertls = "true";
|
|
dnssec = "false";
|
|
};
|
|
networking = {
|
|
hostName = hostname;
|
|
domain = "price-hiller.com";
|
|
nameservers = [
|
|
"194.242.2.2#dns.mullvad.net"
|
|
"2a07:e340::2#dns.mullvad.net"
|
|
"91.239.100.100#anycast.uncensoreddns.org"
|
|
"2001:67c:28a4::#anycast.uncensoreddns.org"
|
|
];
|
|
useNetworkd = true;
|
|
};
|
|
} |