Price Hiller
02334f5601
All checks were successful
Check Formatting of Files / Check-Formatting (push) Successful in 1m14s
27 lines
707 B
Nix
Executable File
27 lines
707 B
Nix
Executable File
{ pkgs, config, ... }:
|
|
{
|
|
security.sudo.wheelNeedsPassword = false;
|
|
users.mutableUsers = false;
|
|
users.users = {
|
|
root.hashedPasswordFile = config.age.secrets.users-root-pw.path;
|
|
price = {
|
|
isNormalUser = true;
|
|
extraGroups = [ "wheel" ];
|
|
shell = pkgs.bash;
|
|
hashedPasswordFile = config.age.secrets.users-price-pw.path;
|
|
openssh.authorizedKeys.keys = [
|
|
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIOkWsSntg1ufF40cALcIBA7WZhiU/f0cncqq0pcp+DZY openpgp:0x15993C90"
|
|
];
|
|
};
|
|
};
|
|
environment.persistence.ephemeral.users = {
|
|
price = {
|
|
files = [ ".bash_history" ];
|
|
};
|
|
root = {
|
|
home = "/root";
|
|
files = [ ".bash_history" ];
|
|
};
|
|
};
|
|
}
|