dots/users/price/conf/gpg/default.nix
Price Hiller 8cb9263e9e
Some checks are pending
Check Formatting of Files / Check-Formatting (push) Waiting to run
refactor(home/price): use gtk2 pinentry package
2024-10-19 16:20:20 -05:00

31 lines
666 B
Nix

{ pkgs, config, ... }:
{
programs.gpg = {
homedir = "${config.xdg.dataHome}/gnupg";
enable = true;
mutableKeys = false;
mutableTrust = false;
scdaemonSettings = {
disable-ccid = true;
};
publicKeys = [
{
source = ./public-gpg-yubikey.asc;
trust = "ultimate";
}
];
};
services.gpg-agent = {
enable = true;
enableSshSupport = true;
enableZshIntegration = true;
pinentryPackage = pkgs.pinentry-gtk2;
maxCacheTtl = 14400;
maxCacheTtlSsh = 14400;
sshKeys = [ "530D3EC95C32AB9EC33714AAF865738D6E77680A" ];
extraConfig = ''
allow-loopback-pinentry
'';
};
}